Setting up Corda - Step Run 'Install' Configuration fails


(arnab maity) #1

I am setting up Corda on Windows.
When i run the ‘Install’ configuration , i get no success or failure messages.It shows ‘Run Build’ and stops there with no message at all.

My suggestion , there should be a step by step guide in detail with screen prints of each step for the installation.

Please let me know how do i get around this problem. Attached is a screen shot of the problem .

Thanks


(Joel Dudley) #2

Hi Arnab,

Sorry about that. You have to import the Gradle project first, by clicking “Import Gradle project” in the Event Log at the bottom on IntelliJ. The Install should then run fine.

We cover the set-up process in the docs, here: https://docs.corda.net/getting-set-up.html, and some set-up troubleshooting information here: https://docs.corda.net/getting-set-up-fault-finding.html.

Best,
Joel


(Roger Willis) #3

What do you want to do? Run some demo apps or build your own app? The documentation is your friend in both cases! :slight_smile:

I note in the screenshot above, you haven’t linked the gradle project to IntelliJ, you have to do this in order to build Corda (gradle is our build tool). From the getting started page:

When opening the Corda project for the first time from the IntelliJ splash screen, please use “Open” and then agree to import the Gradle project from the popup bubble. Don’t pick “Import” on the splash screen, because a bug in IntelliJ will cause the pre-packaged run configurations to be erased. If you see this warning too late, it’s no problem, just use git checkout .idea/runConfiguration or the version control tab in IntelliJ to undelete the files.

For running the demos look at this page: https://docs.corda.net/running-the-demos.html

For building the CorDapp Template which you can use as a base for building your own apps then look at: https://docs.corda.net/tutorial-cordapp.html

Did you see the docs mentioned above before you started? Or were they not easy to find? Where did you look first? Let me know and we can optimise the flow for new developers. Also as you say a step by step guide with screens also helps.

Cheers


(arnab maity) #4

Attached is the error after importing as Gradle project.
Am i still going wrong?


(Roger Willis) #5

That’s because you are not using gradle to build corda!

Go to view > tool windows > click on gradle

A side bar will open up on the right.

On the root gradle project (corda-project) click the plus sign, expand “tasks” then expand “other” and “build”. You will then see all the gradle tasks you can run. click them to run.

Alternatively the easier way is to just run gradlew.bat install from the root project directory.

This might be helpful: https://docs.corda.net/tutorial-cordapp.html


(Charles) #6

IDEA could be smoother about this i.e. I imported the project from Github via IDEA’s import process , and it waits to ask as an event pop up , it knows its a Gradle project, I guess once you get used to it , you get it, but for the unacquainted its not as intuitive.

Anyhow, I do get an issue nonetheless with the very last item on the task list i.e.


(arnab maity) #7

As directed i see the gradle projects on the right. But on running the result is still the same. Am i going wrong completely somewhere.


(Roger Willis) #8

Have you tried cloning a fresh Corda repo and installing from the command line? E.g.

git clone https://github.com/corda/corda
cd corda
gradlew.bat install

Let me know if that works. If not then paste the gradle error here and we can look into it.


(Akshay) #9

I am getting error “Failed to create netty connection”.

E 10:44:15 [main] core.client.createConnection - AMQ214016: Failed to create netty connection
javax.net.ssl.SSLException: handshake timed out
at io.netty.handler.ssl.SslHandler.handshake(…)(Unknown Source) ~[netty-all-4.1.9.Final.jar:4.1.9.Final]

Can anyone help me with this.